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The only guide you’ll need to create 

Boardroom-ready charts 

…get the insider tips to present various business metrics 
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In this tutorial, we shall explore some important considerations while creating visuals in Excel, that will 

help you to better communicate your message. 

 

 

 

 

Tips to create Excel 

charts that inspire 
…guide the consumer to understand your message 
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Tip #1: Change Units Display 

Whenever you plot a chart that has huge numbers (millions, billions, etc.), it will make your charts more 

neat and legible if you could edit the axis values to display the values at a higher scale as opposed to 

showing the absolute value. 

 

Steps involved: 

1. Right click the vertical axis and choose Format Axis from the shortcut menu. 

2. On the Format Axis window that shows up, go to Axis Options >>Display Units >>select your 

preferred scale. Ensure you also indicate the same scale on the chart title or that axis title. 
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Tip #2: Always start axis units at zero 

I have come across charts in various forums that when you look keenly you will realize they misrepresent 

the message. It is sometimes tempting to imagine, say for instance, because the least value in your chart 

series is say 14 million (for argument sake), then it would be okay to change the vertical axis to start from, 

say the 13 million mark. 

It is advisable to not change the starting point. As you can see from the chart below, the visual 

appearance of the highlighted series on the chart on the right would imply the August value is a tenth of 

the July values. This is misleading, isn’t it? 
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Tip #3: Conditional format your charts 

When reporting performance against set targets, you may choose to show both the actual value against 

the target value series side by side. At other times, the context may be just to show the variance to target 

series alone. 

In this case, you will expect to have some positive and negative values. 

When plotting these variances, most analysts wish to show a different colour for positive values and a 

different one for the negative ones. Unfortunately, the colouring is done manually! 

This tip is the least unknown. The steps below will enable you to set the chart to be coloured conditionally 

based on whether a value is positive or negative. 

Steps involved: 

1. Insert the chart as usual. That is, select the data you wish to plot then press ALT+F1 

2. Right click one of the series/bars >>Format Data Series… 
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3. On the Format Data Series options >>Fill & Line >>select Solid fill >>tick “Invert if negative” 

>>choose your preferred colours to differentiate the positive from the negative values. 

4. Tidy up the chart 
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Tip #4: Dynamic chart titles 

When you are creating a chart for your reports and dashboards, it is important to have descriptive titles 

that give context to the chart, signaling the underlying message you wish to put across. 

To do this, you need to link the chart title to a cell in your worksheet that has the text to be displayed. 

Next, ensure that this cell is formula driven to accommodate the user selections/interactions (assuming 

you have slicers or drop-down lists or form controls that the user selects an item to display). 

Take a look at the image below (check the Excel file attached). 

 

Notice the chart title is a function of the various parameters coming from the data. 
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As the name suggests, in-cell charts in Excel in most cases occupy a single cell. These types of charts can 

be very useful especially when one is building a dashboard where the space needs to be optimized for the 

various KPIs to be shown. 

 

 

 

 

In-cell charts 

In Excel 
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Present Data Visually Using In-Cell Charts (REPT function) 

The REPT function allows you to repeat a given value (number or text) a given number of times. 

For instance, to repeat a number 5 three times we would have: 

 

...and the result would be 555. 

With that in mind, let us assume you are tracking targets of various branches in your business in terms of 

sales performance. From your system you’re able to extract the following data. 

 

To visualize the percentage achievement, we can use the REPT function to repeat the pipe symbol (“|”) a 

given number of times. The number of times will be the percentage achievement BUT in different 

scenarios, you can use any factor that makes sense to you. 

Thus in F5 above, we shall use the simple formula: 

=REPT ("|", E5*150) 

That is, we repeat the pipe symbol with a given factor (E5*150). 
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By multiplying with E5 which is the percentage achieved, we ensure the size of our in-cell chart once 

complete will always be proportional to this percentage. The 150 in the formula is arbitrary and you 

should experiment with a reasonable value. 

The pipe symbol is located in different places on your keyboard depending on which make of computer 

you have. Alternatively, you can insert the symbol from the Insert menu >>Symbols. 

The next step is to change the font type of these cells –the preferred ones are: 

• Playbill • Stencil • Niagara Solid 

These font types work best with a font size of between 8 and 14 …but you can experiment to your fit. You 

can also change the font colour of the cells in F5:F9 to your preferred colour. 

 

You can find out how to implement in-cell column charts using the REPT function. 

https://www.facebook.com/BillWilliamsK/
https://twitter.com/BillWilliamsK
https://www.linkedin.com/in/william-kiarie-baab977a/
http://excelchamps.com/blog/2016/03/in-cell-column-chart-with-rept-function/


©2017 Data Cycle Analytics Ltd  Email: consulting@datacycleanalytics.com 

 

Connect with us:                 

Using Conditional Formatting Data Bars 

Conditional formatting is one of the underutilized features in Excel. Luckily, we can use it to create some 

nice in-cell charts especially if you want to share both the visual and the underlying numbers. 

We shall use the data in the preceding section and plot the percentage achievement as bar chart. Here is 

the data: 

 

In cell E5 we only need to equate it to the value in D5 and autofill the formula. 

We then select the range E5:E9 and from the Home tab, we go to Conditional Formatting and insert a 

data bar –solid fill (choose any colour). 
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Finally, since we have the percentages showing in the adjacent column, we don’t need to display them. 

Thus, we select the cells again and on the Conditional Formatting options, choose Manage Rules… In the 

window that pops up, click on Edit Rules and tick the option to Show Bar Only. At this point you can also 

adjust the colour if you may. 
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With a few adjustments on the fill colour of the cells in your worksheet, you can have a better feel: 

 

Additional resource: 

Chandoo also has an awesome piece illustrating how you can use 5-star rating using conditional 

formatting for scenarios such as product reviews, ratings on customer satisfaction, ratings about various 

customer touch points in your organization, etc. 

 

Use of Sparklines in Excel 

Sparklines came about in Excel 2010 and are accessible from the Insert menu on the ribbon. They provide 

visual representation of data in a single cell. They give you the ability to show data trends in your Excel 

dashboards,  

There are 3 types of Sparklines as you can see below. 
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Line/Column Sparkline 

These two types are similar to the normal line/column chart with respect to their usage. They are useful 

when you just want to see the general trend (upward, downward, or cyclical) in your data, and help answer 

questions such as the magnitude of fluctuations in your data. 

For instance, you could use them to show the past 12 months to date trends for sales or temperatures for 

different regions. 

Given the data below, we can implement a line or a column Sparkline as follows. 

 

 

Select cells C3:C6 and from the Insert menu, click the Line Sparkline. You will be prompted to specify the 

data source. Select the range from E3 to J6 and press OK. 
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Once you get the first version of the micro line charts, a contextual Sparkline Tools menu appears where 

you can further customize the Sparklines. 

 

For example, in the figure above, I have adjusted the Sparkline to display Markers by ensuring I tick that 

option in the figure above. Likewise, I have ticked the High Point and Low Point options and adjusted 

the Marker Colour to Green and Red respectively. Further, I have adjusted the line weight from the 

Sparkline Colour options above. This gives me the following. 

 

By following a similar approach, you can end up with the following column Sparkline. 

 

NOTICE that these two types of Sparklines can display both positive and negative values. You can tick the 

Negative Points option in the Sparkline Tools contextual menu to highlight. 
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Win/Loss Sparklines 

This type of Sparklines is useful for binary data, where you only want to highlight any one of two 

scenarios. For instance, negative changes versus positive changes, profits or loss points. 

NOTE that the size of the bar displayed is not meaningful, and hence cannot be used for comparison 

purposes. 

We have the following data set: 

 

We shall insert two columns between M and N above and plot both the Win/Loss and Column Sparklines 

for comparisons. We shall use the year-on-year growth rates for this purpose. Having selected cell N4 in 

the figure below, go to the Insert menu and choose the Win/Loss Sparkline type. When prompted to 

select the range of data, select Q4:U4. 

 

As you can tell from the above, clearly the Win/Loss blocks are the same size whereas the Column ones 

indicate the magnitude. 
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Gauge chart in MS Excel? Really, I’ve never seen it! How do you even imagine it? 

Well, we all have, in one way or the other, monitored progress towards a certain goal in life, haven’t we? 

Whether it is monitoring the sales generated by a department versus their targets, or it is the number of 

kilos one has shed towards a weight loss program, it is always good to have the results of this visualized. 

There are many approaches to measuring progress towards a goal. For instance, we can use a bullet chart 

to monitor performance (see how to create one below). 

In this article, we shall look at an alternative to the bullet chart and go through the steps involved in 

creating a gauge chart in MS Excel. 

It is that time of the year when majority are setting their goals for 2017. One of the cravings for many, I 

included, is to achieve financial freedom. 

Gauge charts 

In Excel 

Speedometers to monitor progress towards a goal 
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I recently read a tweet that was running on the hashtag 52WeekChallenge. The idea was that if you can 

save a 100 Kenya Shillings (approx. USD $1) in the first week, KSH 200 in the second week, KSH 300 in the 

third week… and so on until the last week of the year, you would target to save not less than KSH 137,800 

(approx. USD $1,378) which, truth be told is good enough to start a business or go for a holiday. 

We shall be looking at some data for 2015 where my colleague did take up the challenge. He used to save 

every week and in most cases, would send the money through his mobile phone. 

The Data 

The tables below are the weekly targets and a bank statement of the account in which he saved the 

monies. 

 

At any one time in the course of the year, we want to visualize the status of this weekly challenge, i.e. the 

percentage achieved. 
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Prepping the data for analysis 

To achieve our goal, we need to introduce some helper/auxiliary columns in the worksheet with the 

targets. We shall need to know the cumulative target and the closing bank balances for each week, as 

illustrated below: 

 

We have used the following formulas in columns E to H: 

Cell E2:  =SUM($D$2:D2) 

Cell F2:  =INDEX(Bank!$E:$E,MATCH($B2,Bank!$B:$B,1)) 

Cell G2:  =TEXT($B2,"mmm") 

Cell H2:  ="Wk "&MIN(WEEKNUM($B2),52) 

What is a Gauge Chart? 

A gauge chart or a dial chart in Excel is a combination of a Doughnut chart and a Pie chart. The Doughnut 

chart is used to show the qualitative scale, usually from 0 to 100%. The Pie chart is used to show the dial 

or the pointer for the actual value at a given point in time. 
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The Analysis 

At any one time, based on the week selected by the user, we shall be tracking the year-to-date (YTD) 

status as at that week. We therefore need to insert a slicer (or a combo / drop down list) to allow the user 

to specify the week ending date. 

Using the ‘Targets’ worksheet we insert a pivot table, and drag the week ending column into the filter and 

also proceed to insert a slicer for the week ending and month columns (if you are not familiar with slicers 

read this article from Chandoo). 

 

On the name box, we shall name cell C5 above as “selWeekEnding”. 

Next, we summarize the YTD targets and actuals as follows: 

 

In the formulas above, you will see the text “SampleData” -this is just the name given to the table with the 

targets and transactions data. What follows in square brackets, [ ], is the column name in the table. Learn 

more on Excel Tables here. 
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Data for the Doughnut Chart 

The next thing we do is to define the qualitative scale for our gauge chart. In most cases, the gauge chart 

will have 3 categories (i.e. Red, Amber, Green) but you can include as many as reasonably possible. For 

our case, we have defined 0 to 45% as Red, 45 to 80% as Amber, and 80 to 100% as Green zone, as shown 

below. In actual sense, therefore, the size of Amber is 35% (difference between 80% and 45%) whereas the 

Green is 20%. 

 

To get the target levels values that are representative of the various zones, we shall apply the PERCENTILE 

function on the array of values between 0 (zero) and the target YTD. The formula is applied in cells 

H11:H14 in the figure below. The sum of these values (cell H15) should total to the YTD target. 
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Data for the Pointer/Dial/Needle 

This shall help us to plot the pie chart that will act as the pointer of the actual bank balance. We shall need 

3 data points as follows: 

• Position of the pointer -i.e. the Actual Bank Balance value 

• Width of the pointer -in most cases this is set to 1 but if you are dealing with huge values like in 

our example, we shall use any other convenient number. We have used 2.5% of the actual bank 

balance YTD. 

• The balancing value -which is a formula that subtracts the sum of the actual bank balance and 

the needle size from the sum of the values used to plot the Doughnut chart in the previous 

section. 

 

Now we have the data needed for our gauge chart. 

Creating the Gauge Scale with a doughnut chart 

1. Select the range G10:H15 in the figure above and from the Insert menu in Excel, plot a doughnut 

chart. 
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2. Right click any of the slices/pies in the resultant chart and select Format Data Series from the 

shortcut menu that appears. 

On the Format Data Series dialog box, adjust the “Angle of first slice” to 270%. 

Next, select the wedge on the bottom (labelled blank area and shaded blue at this juncture) and from 

the Format Data Series, change the Fill colour to none (No fill). 

 

The two steps above should give you the following chart. 
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Adding the pointer as a pie chart 

1. Right click the Gauge chart you have just created and choose Select data. Alternatively, select the 

chart you have created and from the contextual Design menu on the ribbon, click Select data. 

 

2. On the dialogue box that pops up, (1) click the Add button and select the cell F18 as the series name, 

and specify the series values as the 3 data points we created above for the pie chart data. Next, (2) 

click the Edit button and on the dialog box that appears (the Axis Labels box), select the data points 

for the pie chart data in the following order -G20, G19 and G21. Use the CTRL key. 

Caution: The numbers you see on the screenshot may not necessarily match what you have in yours. 

What is important is that you do not skip any of the steps. 
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3. You should have the chart looking like the following: 

 

4. We shall format the outer ring to make it a pie chart on a secondary axis and only retain the smallest 

pie which is our needle/pointer. Do the following: 

a. Right click any of the pies in the outer ring and select Format Data Series. The Format Data 

Series dialog will appear / pop up. Set the fill colour of the blue and light gray series to No fill 
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and the border colour to no border (or none). Note that you would need to select each series 

separately (click on it 2 times don’t double click). 

 

b. In a similar way, format the smallest pie to a colour of your choice. A black or a dark blue 

normally blends very well. You should end up with a chart similar to the one below. 

 

c. Select the chart area and from the contextual Format menu, select the pointer data series. 
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d. Once selected, go to the contextual Design menu and click Change Chart Type (or right 

click the selected series and choose Change Series Chart Type… On the window that pops 

up, change the series for pointer data to Secondary Axis and plot as a Pie chart. 

 

The above step will result into the chart shown below. 

 

e. Select the Pointer Data series again and adjust the angle of first slice to 270%. If you have 

trouble selecting the series, go to Format menu and select from there as we did in (c) above. 
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Final touches on the gauge chart 

The final stage of this chart will be formatting the Doughnut (qualitative scale) series into our preferred 

colours (normally, Red, Amber, Green), as well as add data labels to show the actual value against the 

pointer. 

5. To fill the colours to Red, Amber, Green we select the respective series from the Format menu. 

 

At this point, you may face trouble trying to select a single data point. 

The trick is -Once the entire series has been selected, use the left/right arrows on the keyboard to select 

a specific data point… then fill with appropriate colours. 
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6. The final step is to set the pointer value to the actual YTD savings. 

Select the Pointer Data series and from the Design menu or the Chart Elements icon on the chart, 

select Data labels and set the same to Outside end. Next, select the data labels and press CTRL+1 to 

format. On the Format Data Labels dialog box, choose/tick the Category Name instead of Value. 

 

You will end up with the following chart. 

 

7. Finally, clean the chart of unnecessary items. For instance, click on the other data labels (one at a go) 

and press delete, apart from the one indicating the actual savings YTD. You can also work on the fill 
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colours, add a nob at the centre, add a text box to indicate the status, and any other final touches of 

your choice. The final look could be something like the one shown below. 

 

Final thoughts 

As you have seen, creating a gauge chart isn’t a hard task to accomplish. With a few tweaks on the 

available charts we were able to create one. 

There are those who argue in favor or against the use of gauge charts. Those who argue against it say it 

takes a lot of space in, say a dashboard, but provides little info. As such, they propose to use a bullet chart 

which gives more context of the KPI status. 

I leave that for you to decide which one best fits your scenario. 

In my opinion though, apart from giving more context for your data, a bullet chart doesn’t fall short in 

scenarios where the savings exceed the target (>100%). As you may have noticed with a Gauge chart, it is 

assumed the scale runs up-to a 100 percent. 
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Creating interactive charts, or dynamic charts if you prefer, is one of the rare skills among Excel users. 

There are many approaches that make Excel as a tool very interesting to use… and to be honest, creating 

dynamic charts is one of my favourite. 

What makes a chart or a table dynamic is being able to change the underlying data set. You can employ 

different ways but the common ones include: 

1. Using form controls such as combo boxes, spin buttons, scroll bars or option buttons 

2. Using pick lists (or drop-down lists if you like) 

3. Using slicers for those with MS Office 2010 and above 

4. Using macros / VBA 

5. Using Excel tables 

Today we are going to look at how we can leverage on a scroll bar to create a dynamic scrolling chart. 

Add interaction using 

Scrolling charts 

…very useful when presenting a long list of data 
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We are going to use data that shows monthly average prices for crude oil imports for a span of 4 years, 

2011 to 2014, for our illustration. 

 

 

We have a total of 48 data points but we shall be showing 9 data points at any single view and then allow 

the user to scroll to see the rest of the data set. 

Preparing the data for the scrolling chart 

The idea behind any dynamic chart in most cases involves extracting a subset of the original data set in 

another section in your worksheet. 

We shall be combining the year and the month column and use the combined column for our horizontal 

axis. In cell E5, we will enter the following formula: 

=C5 & CHAR (10) & B5 

https://www.facebook.com/BillWilliamsK/
https://twitter.com/BillWilliamsK
https://www.linkedin.com/in/william-kiarie-baab977a/


©2017 Data Cycle Analytics Ltd  Email: consulting@datacycleanalytics.com 

 

Connect with us:                 

CHAR (10) in the above formula acts as a hard return (equivalent to ALT+ENTER) so that we can force the 

year to appear in a new line in our chart and therefore avoid having the horizontal axis labels for our chart 

slanted. 

 

For this chart, we shall only need column D and E. 

We therefore need to extract 9 data points from this data. We shall do this in the following area on our 

worksheet. 

 

The next step will involve generating these 9 data points depending on the scroll position. Initially, let us 

just type a dummy number in cell H3… but this cell will be populated by the scroll bar in Excel. 
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In cells H5 and I5 we shall enter the following formula and drag it in the other adjacent cells. 

Cell H5:  =INDEX (E5:$E$52, $H$3) 

Cell I5:  =INDEX (D5:D$52, $H$3) 

Notice how we fix the last data point in row 52 but allow the starting point to adjust as we autofill the 

formulae. 

This is because the number generated by the scroll bar is constant, as you shall see later in this article. As 

such the range needs to adjust downward or upwards as the scroll bar positon changes …much like a 

slider. 

Plot the chart 

We shall go ahead and plot a line chart based on this new data set. At this point we shall not worry much 

about the formatting and customization. 

Select the data set, cells H4:I13, and from the Insert menu select the stacked line chart with markers to 

have the following: 
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Creating a Scroll Bar for the Interactive Chart 

To create a scroll bar, we shall need to access the Developer menu on the Ribbon. This however is not a 

default menu and you may have to enable it first. 

Enabling the developer menu 

Right click anywhere on the ribbon and select customize the ribbon. 

 

On the window that appears, just check the box next to the Developer option …see below. Press OK. 

 

To insert the scroll bar, we head to the developer menu and insert a scroll bar, i.e. Developer menu 

>>Insert >>Scroll bar 
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Once you select the scroll bar, hold down your left mouse button and draw a sizeable horizontal bar next 

to your chart. 

 

Next, right click the scroll bar and select Format control to set the properties for this scroll bar. On the 

control tab, set the properties as shown in the figure that follows. 
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Understanding the scroll bar properties 

Current value: This is the current scroll bar position. You can initially set this to 1 but for us we have 

defaulted it to 11, which is the random number we had chosen earlier on. 

Minimum value:  This is the lowest value that your scroll bar can return. In most cases this will be one (1). 

But in some scenarios, for instance, if your scroll bar allows you to scan through a list of years between 

2008 to 2017, you should set this to 2008 since this is the earliest year in your series. 

Maximum value: This value represents the maximum change that can happen such that the first value 

or data point in your original list becomes the first data point in the last “X” (in our case, last 9) items for our 

chart. [I want you to read this again until it sinks somewhere at the back of your mind.] 

I have devised a way to compute what this value should be as follows: 

(Total no. of data points less the number of data points to display) + 1 

In our case, 

(48-9) + 1 =40 

Incremental change: This is the change that will happen when the user scrolls one position forward or 

backward using the arrows at the beginning or end of the scroll bar. For this example, we want the data 

points to be scanned one row at a time. 

Page change: This is the change that will happen when the user clicks anywhere on top of the scroll bar, 

besides the arrows. 

Cell link: Majority of the form controls in the Developer menu will always generate an index/number 

upon the user making a selection. This number need to go somewhere and that is the purpose of this cell. 

In this example, we specify H3 as the link so that the formula we had done earlier on gives results based 

on what is selected on the scroll bar. 
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Final touches on the chart 

By this time if you scroll the bar you should see the chart updating accordingly. If there is a step that was 

not clear, this is the time to revisit it. 

This bonus step involves customizing the chart elements such as the chart and axes titles. Further, change 

the line colour if you prefer and make any other changes that may be necessary. 

For instance, select the chart title place holder, click inside the formula bar, press = and select cell A1 to link 

the chart title. 

Make all elements such as the gridlines, chart title and horizontal axis labels faint in colour to allow the 

line to stand out. 

One last tip: To ensure that you can move both the chart and the scroll bar at one go” 

• Hold down the CTRL key on the keyboard and select the chart 

• While still holding the CTRL key, select the scroll bar 

• You will notice Drawing Tools <Format> menu on the ribbon from which you choose group to 

group the 2 selected items 

 

The final chart looks like the one shown below. 
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Read more about dynamic, scrolling charts here: Sliders on an Excel chart by Darren Hall and creating sexy 

scrolling charts in Excel by Annie Cushing. 

 

 

 

 

 

 

 

 

 

https://www.facebook.com/BillWilliamsK/
https://twitter.com/BillWilliamsK
https://www.linkedin.com/in/william-kiarie-baab977a/
http://dedicatedexcel.com/create-an-excel-chart-with-a-scroll-bar/
http://marketingland.com/dashboard-series-creating-sexy-scrolling-charts-in-excel-51759
http://marketingland.com/dashboard-series-creating-sexy-scrolling-charts-in-excel-51759


©2017 Data Cycle Analytics Ltd  Email: consulting@datacycleanalytics.com 

 

Connect with us:                 

 

 

 

 

 

 

 

The first time you come across this name for a chart, it’s even difficult to figure out what it would look like. 

But yes, it is possible! 

A bullet basically is a projectile towards a given target. Bullet charts are useful to measure progress towards 

a goal or some targeted value. More than often as a manager or departmental head, you are always 

monitoring your milestones –Actual versus Target. 

A bullet chart gives more than how far you are from your goal. It gives you the context! A typical bullet 

chart looks like this: 

 

Progress towards a goal using 

Bullet charts 

…gives context to performance achieved 
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The data points required to create this chart in Excel fall into these three categories: 

1. Primary Measure -i.e. the Actual Value recorded, e.g. YTD Revenue 

2. Standard Measure -this is the Target Value to be compared with the Primary Measure 

3. Qualitative bands for performance -such as Poor, Fair, Satisfactory, Good and Excellent 

There are a couple of ways to create this chart but this article will focus on a fairly simple approach. 

Step 1: Arrange your data as shown below. 

The low, mid & high will provide the context in terms of a qualitative scale for your chart. The values you 

use here will depend on what you consider good or bad in terms of performance. 

 

Step 2: Select B2:C7 and insert a 2D Stacked Column chart. 

As this data is in a single column, it will be plotted as separate/clustered columns instead of stacked ones. 

Go to Design menu and choose Switch Row/Column. This will give you one column with all the data 

points as shown below. 
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Step 3: Change Series Chart Type for Target Bar 

Right-click on the Target bar and choose “Change Series chart type…” on the dialog box that pops up, 

change the Target Value chart type to Stacked Line with Markers, and put it on the secondary axis. 

 

Upon clicking OK, there would be a dot in the middle of the bar (see the figure above). Notice the primary 

and secondary vertical scales are different. To harmonize, select the secondary vertical axis and delete it. 

Step 4: Format the Actual Series 

Right click the Actual bar and choose Format Data Series…This provides you with various format options. 

Under Series Options, check the Secondary Axis check box and adjust the Gap Width for this series to, 

say 350%. You can give this series a Dark Blue fill with no Borders. 
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Step 5: Format the Target Value Marker Dot 

Select the Target value marker dot and press CTRL+1 to format it. In the Format Data Series dialog box 

and make the following changes: 

• Marker Options: choose Built-in and make the following adjustments: 

o Type -select dash 

o Size -adjust to 18 (or one that fits your chart) 

 

• Fill Option: select ‘Solid fill’ and use Red colour or any other colour that complements your chart 

• Line Options: choose ‘No line’ 

• Border Options: choose ‘No line’ 

Step 6: Format the Qualitative Bands 

Right click the qualitative ranges one at a go and change its feel colour. Preferably, blue or gray shades are 

easy on charts. Give these ranges a gradient feel by selecting a fill colour with varying degrees of 

transparency. 
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Further, adjust the gap width of these bands to, say 150%. 

You should have the following at this stage: 

 

Step 7: Re-size your Chart and Remove Chart Junk 

For instance, delete the gridlines and the legend for the 3 qualitative bands. You may also add tick marks 

to the vertical value axis. 

Once you follow all the steps above, you will end up with a chart like the one below. You can introduce 

this power-packed visual in your next dashboard presentation. 
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Creating a Waterfall Chart with Negatives in Excel 

As you may be aware, a waterfall chart, which is also called a bridge or cascade chart, provides an easy 

way to illustrate how an initial value is impacted by a series of intermediate rises and falls in the course of 

time. That is, it shows the cumulative effect. 

They can be used in almost every field. Examples include: 

• Inventory analysis 

• Projected profit analysis 

• Employee count analysis 

For better insights and impact, endeavor to show the underlying drivers to the change! This could be in 

form of market share movements, impact of competitor pricing, store number movements (margins), etc. 

There are more than 2 ways to create this type of chart in Excel. I’ve discussed one that uses stacked 

column chart in this blog post. As you may have experienced, the methodology of using stacked column 

chart fails when you have negative values that force, say the final/intermediate cumulative value(s) to be 

below the zero axis. 

Show underlying drivers of change 

Waterfall charts 

…with major negative changes 
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With Excel 2016, the Waterfall chart is a native chart and doesn’t require a lot of work. But those with Excel 

2013 and below, read on. 

We shall focus on a scenario with negative values, but this methodology should work either way. 

 How to build 

Assuming you have data for an income statement as shown below. We want to illustrate how the net 

revenue is impacted by the series of inflows and outflows. 

 

Step 1: Rearrange your data 

In this example, we shall take a simplified approach where we shall skip the intermediary subtotals. We 

shall hence extract the main line items and based on these values, we shall generate 3 extra columns as 

shown below. 
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Whereas the stacked column approach relies on a floating bar to support the positive and negative 

values above the zero axis, our approach is based on 2D line charts and a line chart feature called up-

down bars. 

If you have two series of data, up-down bars are used to emphasize the difference in measurement 

between the two data series. Hence, the extra columns (Before and After) in the figure above! These two 

columns represent the resultant values before and after adding a line item to the previous total. 

The calculations are as follows: 

Cell H3: =G3 

Cell H9: =G9 

Cell I4: = SUM(G$3:G3) 

Cell J4: = SUM(G$3:G4) 

Step 2: Create a 2D line chart from the before and after columns 

Select cells F2:F9, hold down the CTRL keyboard key and select the range H2:J9 and from the Insert menu, 

select the clustered line with markers. 
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Step 3: Transform the chart to a waterfall chart 

At this stage, right click the “Ends” series represented by the dots/markers and choose Change series 

chart type… make it a clustered column chart. You will have: 

 

Secondly, select one of the line charts and add up/down bars as shown below or from the Design menu: 
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Lastly, select each data series in turn and set line to "no line" and marker options to “None”: 

    

This is what you should get after setting both data series to "no line": 
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Step 4: Format and clean up the chart 

The following are the final touches that may be necessary: 

a) Select and delete the legends and gridlines 

b) Select up/down bars and change the fill color and border as desired 

c) Change the gap width of the column and the up-down bars to some value close to zero, say 5% 

a. Double click one of the ‘Ends’ column to get the formatting options and change the gap 

width as shown: 

 

https://www.facebook.com/BillWilliamsK/
https://twitter.com/BillWilliamsK
https://www.linkedin.com/in/william-kiarie-baab977a/


©2017 Data Cycle Analytics Ltd  Email: consulting@datacycleanalytics.com 

 

Connect with us:                 

b. For the Up/Down bars, once selected on the chart itself, you would then need to select 

the specific series (either Before or After) from the Format Data Series dialog box. 

 

  Upon selecting the series, the following format options will then be available to adjust. 

   

d) If your chart doesn’t have a lot of categories/series, you may choose to add data labels to your 

chart, and further delete the vertical value axis. This is purely optional and one needs to be 

careful 
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e) To avoid the horizontal axis labels from overlapping with the bars, you can select it and show the 

Labels either at High or Low position. 

 

Here is the final chart having followed every step. 
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